Čerstvé KDE 4.2.1 můžete mít ještě dnes

logo-kdePrávě vyšlo KDE 4.2.1. Zdá se mě být (konečně) použitelné. Na mirrorech se vzápětí objevily balíčky pro Mandriva Linux . Jsou připraveny lidmi kolem KDE, ale zdají se být bezproblémové a KDE 4.2.1 stabilní.

Zaktualizujte stávající zdroje, a přidejte nové.

Pro 64 bit:

urpmi.addmedia –update KDE-421-64 ftp://ftp.fi.muni.cz/pub/kde/stable/4.2.1/Mandriva/2009.0/RPMS/x86_64/
urpmi.addmedia –update KDE-421-noarch ftp://ftp.fi.muni.cz/pub/kde/stable/4.2.1/Mandriva/2009.0/RPMS/noarch/

Pro 32 bit:

urpmi.addmedia –update KDE-421-32 ftp://ftp.fi.muni.cz/pub/kde/stable/4.2.1/Mandriva/2009.0/RPMS/i586/

urpmi.addmedia –update KDE-421-noarch ftp://ftp.fi.muni.cz/pub/kde/stable/4.2.1/Mandriva/2009.0/RPMS/noarch/

A spusťte aktualizaci.

Jak říkají staří Rusové: Enjoy!

37 komentářů

  1. Ivko | 05.03.2009 | 22:43 | Odpovědět

    No neviem, či to iba ja, ale mám taký mierny pocit, že im tam nejaké tie balíčky chýbajú (presnejšie mi ich počítač nechce stiahnuť), a preto to nie je až také ideálne…

    Má ešte niekto taký problém?

    1. Miroslav Cyroň | 05.03.2009 | 23:03 | Odpovědět

      Mě to šlo úplně v pohodě, jen u 2 balíčků to hodilo hlášku o špatných podpisech. Původní KDE bylo 4.1.3, dělal jsem to z GNOME, přes Ovládací cetrum, zdroje Ofic (všechny), Cyron, PLF, MiB ( http://mib.pianetalinux.org/miblight/repository-2/ ), VŠECHNY mám aktualizační.

    2. petr | 06.03.2009 | 06:50 | Odpovědět

      Updatoval jsem z KDE 4.2.0. Proběhlo to bez problémů. Přestal fungovalt Lancelot (respektive funguje ale zcela vytěžuje jedno jádro procesoru) tak jsem se vrátil k KDE menu. Začal fungovat Amarok. Titulky oken mají špatné znaky UTF-8. Dva balíčky se nenainstalovali (zapomněl jsem název). Odinstaloval se Skype, nahradil jsem ho staticky zkompilovanou binárkou a funguje. Odstraněno plno drobných chyb. Více detailů jsem nezkoumal. Jsem spokojený.

      1. bibri | 06.03.2009 | 10:30 | Odpovědět

        Chybu s Lancelotem potvrzuji – chová se tak i u mně (32bit).

        Problémy s balíčky či novou verzí KDE můžete diskutovat ve fóru, je tam na to speciální vlákno:

        http://forum.mandrivalinux.cz/index.php?topic=10220

    3. Ivko | 06.03.2009 | 09:48 | Odpovědět

      Dnes som aktualizoval, všetko šlo OK. Asi sa niečo kazilo v spojení…
      Aj mne sa odinštalovalo Skype. Neviem, či je pre normálneho užívateľa príjemné, že mu odíde program, ktorý musí nahrádzať z bináriek…
      Ináč, veľký rozdiel od KDE 4.2.0 som si nevšimol. Ale konečne je to staré dobré KDE, ktoré je stabilné a FUNGUJE.
      Vďaka vývojárom, že pomysleli aj na nás.

  2. Ged | 06.03.2009 | 10:51 | Odpovědět

    Tak zase jak uz v predchozim pripade v adresach je jedno ftp:// navic

    1. Miroslav Cyroň | 06.03.2009 | 11:55 | Odpovědět

      ?

    2. Ivko | 06.03.2009 | 17:55 | Odpovědět

      Nezdá sa mi, že by bolo jedno ftp:// naviac. Ja som tie riadky jednoducho skopíroval a… divné, dokonca sa mi aj celé KDE dokázalo aktualizovať. Teda asi problém bude niekde inde…

    3. zdenál | 07.03.2009 | 11:24 | Odpovědět

      nauč se něco o protokolech, ať si tady neděláš pravidelně při vydání nové verze kde ostudu 🙂

    4. Ged | 09.03.2009 | 06:48 | Odpovědět

      Beru zpet za cele muze script na zvyraznovani adres z greasemonkey a ja :-$

  3. Laura | 06.03.2009 | 11:58 | Odpovědět

    Při updatu z KDE 4.2.0 proběhlo všechno jak má, s výjimkou dvou balíčků:

    Promiňte, ale následující balíčky nelze vybrat:

    – kipi-plugins-0.2.0-1.rc2.2mdv2009.0.x86_64
    – lib64kipiplugins1-0.2.0-1.rc2.2mdv2009.0.x86_64 (z důvodu nesplněného kipi-plugins-0.2.0-1.rc2.2mdv2009.0.i586)

    druhý nelze vybrat, protože závisí na prvním (chápu), ale proč nelz vybrat první? Nelze je ani vybrat dodatečně po restartu x-serveru jako extra aktualizaci.
    Abych nezapomněla, nemám MandrivuCZ, ale Mandrivu 2009.0 Free x86_64.

  4. David Šindelář | 06.03.2009 | 18:18 | Odpovědět

    Tak jsem vyzkoušel aktualizovat a zatím nemám větší problém. Balíčky, které dělají neplechu při aktualizaci, se odstraní a znovu nainstalují poslední verze ručně. Mám Mandrivu 2009 CZ se všemi aktualizacemi z official a PLF zdrojů. Pouze Lancelot má problémy, jinak OK, doporučuji.

  5. alda81 | 06.03.2009 | 21:16 | Odpovědět

    možná bych místo českých zdrojů použil raději zdroje cizí – sám jsem měl s těmi českými menší problémy, protože u nich chybělo pár balíčků (aktualizoval jsem přímo z KDE 4.1.3.)

    pro 32bit systém bych použil příkazy

    urpmi.addmedia –update KDE-421-noarch ftp://ftp.kde.org/pub/kde/stable/4.2.1/Mandriva/2009.0/RPMS/noarch/
    urpmi.addmedia –update KDE-421-32 ftp://ftp.kde.org/pub/kde/stable/4.2.1/Mandriva/2009.0/RPMS/i586/

    k 64bitovému systému si to každý určitě dokáže odvodit sám

    1. Ivko | 06.03.2009 | 22:12 | Odpovědět

      Ja som aktualizoval tiež z KDE 4.1.3 a to za chodu KDE prostredia, bez odhlasovania alebo zmeny prostredia. Len som si stiahol z cookeru (nekomentujem názory iných…) do počítača balíčky task-kde, task-kde-devel a task-kde-minimal. Tie som (v poradí, ako som vypísal) jednoducho spustil klasickým kliknutím v Dolphin-e. Vyhodilo závislosti, ktoré si samo zobralo už z pridaného zdroja KDE 4.2.1. Po nainštalovaní tých troch balíčkov (a samozrejme všetkých závislostí s tým spojených). Potom som aktualizoval systém.
      Bez akéhokoľvek problému, stabilný a v pohode. Nič som nemusel nastavovať ani meniť. Jednoducho som si všimol, že teraz už mám poriadny systém a to bez problému, počas práce. Ako sa na Mandrivu patrí.

      Zdravím všetkých verných mandrivákov.

      1. Miroslav Cyroň | 07.03.2009 | 14:25 | Odpovědět

        Náhodou bezva postup, užitečný těm, kteří nemají žádné či jen neúplné KDE.

  6. Eagle | 06.03.2009 | 23:33 | Odpovědět

    No, vela sa nezlepsilo. Po spusteni Digikamu sa mi zobrazi hlaska “The application digiKam (digikam) crashed and caused the signal 11 (SIGSEGV).”

    1. alda81 | 06.03.2009 | 23:58 | Odpovědět

      mě digiKam funguje docela přepychově a už dokonce zobrazuje i náhled obrázku, tak jak to dělal ve verzi pro KDE3.5

    2. Petr22 | 08.03.2009 | 06:15 | Odpovědět

      Potvrzuji, Digikam padá a to především při použití lišty s miniaturami obrázků. Po přejetí myškou přes hvězdičky co se na ní ve spodní části zobrazují, mi Digikam pokaždé spadne. Zajímavé je že v KDE4.2.0 to bylo bez problému.

  7. Jiří Pošvic | 07.03.2009 | 00:14 | Odpovědět

    Mám prosbu. Můžete mi někdo polopatě poradit, jak přesně přidat uvedené zdroje. Mandrivu zkouším teprve cca dva měsíce a ještě se s ní se učím.

  8. Vitek | 07.03.2009 | 00:17 | Odpovědět

    Tak jsem provedl taky upgrade na na 4.2.1. Ten proběhl celkem bez problému. Sice mi to poprvé hlásilo, že nějaké balíčky nemůže nainstalovat, ale po druhém spuštění upgrade se mi už všechny balíčky nainstalovaly správně. Zatím jsem narazil pouze na jeden problém. Nejde mi spustit Krusader s root právy. Hlásí mi to chybu:
    kdeinit4: preparing to launch /usr/lib/kde4/libexec/klauncher
    klauncher(27771) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
    kdeinit4: Communication error with launcher. Exiting!
    Přitom pod userem mi Krusader spustit jde. V 4.2.0 nebyl žádný problém.

  9. eM | 07.03.2009 | 10:01 | Odpovědět

    Jako to tady čtu, jsem rád za svoji Vistu 🙂

    1. Miroslav Cyroň | 07.03.2009 | 14:20 | Odpovědět

      To je taky čerstvá supernovinka? Kdy to vyšlo, a kte stáhnout free verzi? Zdůrazuji, že vykopávku starší roku instalovat nebudu. 😀

    2. kotrcka | 07.03.2009 | 14:24 | Odpovědět

      vista, vista.. hmmm

      aha, uz viem.. nie je to ten system, kde po update nabehne obrazovka s textom “configuring updates – stage 3” a so 100 percentami. a pocitac sa milion krat restartuje stale asi po 5 minutach, pricom do systemu sa uz nedostanete (ani posledna funkcna konfiguracia ci posun na posledny bod obnovy nepohol)

      1. eM | 09.03.2009 | 09:51 | Odpovědět

        Ne, to není on.

    3. David Šindelář | 09.03.2009 | 14:26 | Odpovědět

      No, ono tohle ani není tak o samotném systému, ale o grafickém prostředí. Pokud se Vám nelíbí nevychytanost KDE 4, můžete používat starší verzi nebo úplně jiné prostředí na stejném systému. A o tom právě Linux včetně Mandrivy je, můžete si vybrat. Co na to Vista?

    4. Aminux | 09.03.2009 | 19:11 | Odpovědět

      Pokud jseš rád, tak je to jedině dobře. My si ladíme KDE, někdo jiný Gnome nebo Xfce. Někdo zas rád Vistu. Každému co jeho jest. To se mi na tom líbí, že každý má možnost výběru. Proto jsem rád, že je na světě Vista. Čim větší výběr, tim lepší.

  10. al | 08.03.2009 | 21:26 | Odpovědět

    Readme: ftp://ftp.kde.org/pub/kde/stable/4.2.1/Mandriva/2009.0/README

    Zápis v blogu Helia Chissini de Castro: http://www.kdedevelopers.org/node/3909

  11. orlik1 | 09.03.2009 | 08:01 | Odpovědět

    Mne by spise zajimalo, kolik Mb se musi k tomu upgrade stahnout. Mam koupene DVD s 64 B mandrivou, ale musim pouzivat KDE 3.5, protoze KDE 4 mi na pocitaci doslova blbne. A stahovat a zaneradit si system dalsim paskvilem se mi nechce. nemam sice uz telefonni pripojeni, ale to ADSL neni o moc rychlejsi.

    1. David Šindelář | 09.03.2009 | 09:00 | Odpovědět

      On se ten systém ani tak nezaneřádí, prakticky se přepíše původní KDE 4. Mám taky koupenou českou verzi Mandrivy a jedu 64 bit, musím říct, že toto poslední KDE už je opravdu docela použitelné. Navíc po přidání zdrojů a aktualizaci Vám urpmi nejprve sdělí, kolik MB balíčků se bude stahovat, a pak se teprve zeptá, zda chcete aktualizovat.

      1. orlik1 | 09.03.2009 | 11:49 | Odpovědět

        Kdyz jsem tam jednou pridal zdoje od Cyrone, z ftp a dalsi doporucene, tak mi to napsale (nevim, ktery to byl upgrade), ze musi stahnout a nahradit 900M balicku(asi). A to potom 1-2 kraz za tyden hlasilo, ze je k dispozici dalsi upgrade a jednou v te spleti balicku jsem spatne neco zaskrtl, “odinstalovalo mi to neco z jadra, naco smazalo”, takze jsem nakonec preinstalovaval celou mandrivu.
        Nemam odvahu pri mem pomalem pripojeni tohle riskovat. Stale se mi jeste nepodarilo priblizit nastaveni s 2009, ktere jsem mel ve 2008.

  12. jackrash | 09.03.2009 | 22:35 | Odpovědět

    Počkejte si tak pul roku, nemá to cenu instalovat! Nic nejde a není to stabilní!

  13. orlik1 | 10.03.2009 | 07:11 | Odpovědět

    Tak jsem se rozhodl pro upgrade. Nemohu referovat o stabilite za tak kratkou dobu. Oproti zakladni verzi nepada po stisknuti MENU, problemy s listami(asi jim nerozumim) pretrvavaji. V minulosti se mi podarilo zrusit spodni listu s klavesou MENU, okny ploch atd. Podarilo se mi je prihrat na horni listu, ale tou nelze jednoduse posunovat shora dolu.
    Jako chybu vidim i to, ze pokud jsem z blbosti a nevedomky zmaximalizoval listu na celou obrazovku, neni pod ni nic videt, co se provadi. Musel jsem 3x zresetovat PC az se mi jak takz podarilo se listy zbavit. Mozna ze pokud nebude tato verze zlobit, asi u ni zustanu i proto, ze pristi verze se vracet zpet k tomu lepsimuz 3.5 nebudou. Bohuzel mandriva prejima ruzna cinkrlatka a serepeticky aby se snad “vyrovnala” Vistam.

  14. sine.nomine | 10.03.2009 | 10:16 | Odpovědět

    nevim proc, ale me 4.2.1 vcera zacala padat… 🙁 a to uplne. chvili tma a pak kdm…

    1. sine.nomine | 10.03.2009 | 10:18 | Odpovědět

      a musel jsem smazat nastaveni plasmy, aby neslitla hned po prihlaseni. bum. dalsi pad, vracim se na cas ke gnome….

      1. sine.nomine | 10.03.2009 | 11:57 | Odpovědět

        tak asi se porouchal openchrome ovladac… po instalaci nejnovejsi svn verze to vypada stabilne

        1. kolemjdoucí | 27.03.2009 | 20:25 | Odpovědět

          Ne enjoj, ale hokej. 🙂

Leave a comment

Sorry, you must be logged in to post a comment. Login