Další zdroje KDE4.2 pro Mandrivu 2009.0

Sice s lehkým zpožděním, ale přece jen se objevily oficiálnější zdroje KDE4.2 pro MandrivaLinux 2009.0. Má to na svědomí Mandriva KDE tým pod KDE projektem (nikoli tedy Mandriva s.a.). Tyto zdroje najdete na ftp serveru projektu KDE (ftp.kde.org). Další informace a postup přidání zdrojů najdete v článku.

Z readme u balíčků vyplývá následující:

  • Současná verze phonon-gstreamer není zcela v pořádku. Doporučuje se nainstalovat a používat phonon-xine.
  • Některá – především pokročilá visuální – nastavení původního KDE4.1.x se mohou ztratit.
  • Stará podpora msn v programu Kopete byla odstraněna ve prospěch nové knihovny libmsn a migrace ještě není hotova. Bude třeba přidat účet u WLM/MSN znovu.
  • Po startu PIM aplikací (KMail, Kontact) spustí program Akonadi konverzi PIM informací do vlastní nové databáze. K úplnému dokončení procesu bude třeba restartovat program, který toto spustil.

Jak přidat softwatové zdroje:

32bit.:

urpmi.addmedia –update kde42-20090 ftp://ftp.kde.org/pub/kde/stable/4.2.0/Mandriva/2009.0/RPMS/i586

64bit.:
urpmi.addmedia --update kde42-20090 ftp://ftp.kde.org/pub/kde/stable/4.2.0/Mandriva/2009.0/RPMS/x86_64
Noarch (balíčky pro obě architektury - např. lokalizace): 
urpmi.addmedia --update kde42-20090-noarch ftp://ftp.kde.org/pub/kde/stable/4.2.0/Mandriva/2009.0/RPMS/noarch

32 komentářů

  1. Daniel J. | 06.02.2009 | 13:46 | Odpovědět

    Přidáním těchto zdrojů odpadá nutnost “odebrat” starší balíčky KDE4.1.xx ?
    A stačí jen aktualizovat ?

    1. iPrazdroj | 07.02.2009 | 17:13 | Odpovědět

      Já jsem to tak udělal, jen jsem přidal zdroje, aktualizoval, odhlásil se a vše jede v pohodě. Jen mi to zrušilo pozadí panelů a plochy a při instalaci to řvalo, že nemůže nainstalovat Kopete 4.2 a ještě nějaké dva tři balíčky.

      1. Daniel Jan | 09.02.2009 | 06:45 | Odpovědět

        Pokud jsem dobře pochopil tak tvůj postup byl :
        1 – Instalace z DVD
        2 – přidání zdrojů KDE 4.2 (viz výše)
        3 – přidání zdrojů (obecně dle návodu Cyroně)
        4 – aktualizace
        5 – odhlášení – přihlášení
        6 – OK ??
        Nebo nejprve zaktualizovat KDE4.2. a pak teprve přidat zdroj pro zbytek ?
        Nebo nejprve obecně zaktualizovat a až potom přidat zdroj KDE4.2. a zaktualitovat ?

        1. iPrazdroj | 13.02.2009 | 08:11 | Odpovědět

          Nainstaloval jsem už dříve českou verzi Mandrivy od pana Bíbra a kolektivu. Součástí instalace bylo i nainstalování balíčků z Extra DVD a přidání zdrojů zstenis kvůli lepší verzi OOo. Počítač jsem normálně používal.

          Pak se zde objevily zdroje na KDE 4.2, přidal jsem si je, aktualizoval, odhlášení, přihlášení, a vše jede v pohodě.

          Takže z těch tvých možností asi ta poslední nejvíce odpovídá mému postupu. Nedělal jsem to všechno v jeden den, ale v rozmezí několika dnů, možná týdnů.

      2. Bloud | 09.02.2009 | 13:12 | Odpovědět

        To Kopete jsem tam dostal dodatečně.

        1. iPrazdroj | 13.02.2009 | 08:13 | Odpovědět

          Jo, Kopete mi pak šlo přidat také, ale Digikam stále ne.

    2. jirka | 11.02.2009 | 09:54 | Odpovědět

      jar: a to jsi za to co ti vsechno nefungovalo a musel jsi to vselijak ladit jeste platil penize? 🙂

      1. jar | 11.02.2009 | 12:51 | Odpovědět

        jirka: Ano, koupil jsem si české vydání, což dělám jednou ročně, abych podpořil ty, co se u nás věnují práci na Mandrivě. Ale nemáte pravdu v tom, že to nefungovalo. Český tým se hodně snažil, aby jejich verze 2009.0 byla dobrá a povedlo se jim to. Po instalaci všeho podle návodu v knize jsem měl funkční KDE 4.1.3 a všechny aplikace, které používám a jediná věc, kterou jsem musel udělat, bylo přepnout startovací nabídku na kickoff, protože ta normální shazovala plasmu. Nic víc. Samotná kniha má velmi dobrou úroveň.

        Když už, tak moje námitky směřují přímo k Mandrivě samotné. Rozhodně nebyl dobrý nápad nasadit KDE 4.1 jako hlavní prostředí (jako volbu klidně) a je ostudné, že když už to udělali, neposkytli verzi 4.2 jako běžný update, čímž by svoje uživatele odškodnili. Místo toho si to nechávají až do jarního vydání. Na druhé straně je třeba přiznat, že pravděpodobně jediný způsob jak se nakonec dobrat dobré věci je dát to uživatelům, kteří prověří způsoby použití a hardwarové kombinace, které jsou mimo dosah a představivost běžných a mnohem méně početných testerů.

    3. jirka | 18.02.2009 | 08:05 | Odpovědět

      Ano jsem to ja. Zdravim vas pane poctivy 🙂

    4. jirka | 18.02.2009 | 08:15 | Odpovědět

      Ceske vydani Mandrivy jsem si koupil 2x a to 2006 a 2007 a od te doby kradu, protoze na to nemam a nechce se mi to porad kupovat a taky protoze se mi powerpack libi vic nez ceska verze. A ty reci o tom ze Ceska verze je lepsi protoze je lokalizovana jsou k smichu. Mam powerpack a problemy s lokalizaci nemam. A taky ta 2007 byla proste pro me nepouzitelna byli to vyhozene penize.
      Pocitam s tim ze to smazete tak si to precte aspon ten mazač 🙂
      Timto vas zdravim jirka

      1. e-ott | 18.02.2009 | 10:07 | Odpovědět

        A ty reci o tom ze Ceska verze je lepsi protoze je lokalizovana jsou k smichu. Mam powerpack a problemy s lokalizaci nemam.

        Ty jsi ale hlupák. Navíc chamtivý. Myslíš, že Mandrivu do češtiny překládají Francouzi? Ne, Michal Bukovjan a další lidi (taky jsem na to, pár desítek hodin strávil). A jestli z toho je pak Power pack nebo Free, je z hlediska práce jedno – někdo ji udělat a zaplatit musí… Také na tohle jdou peníze, které se vydělají např. prodejem knih..

    5. jirka | 18.02.2009 | 10:49 | Odpovědět

      Reci o lokalizaci? Jen pisu to co propaguji ti co se snazi prosadit Ceskou verzy Mandrivy s priruckou.
      Hlupak? No nevim ale klidne jestli chces.
      Chamtivy? Myslim ze ne, ale nemuzu preci platit za neco co mi nespusti vsechen hardware pokud u toho neprosedim X hodin a jeste abych se naucil programovat. Pisu preci Koupil jsem si Mandrivu 2x myslim ze to staci.
      A taky to ze jsem se priznal ze jsem si stahnul powerpack 🙂 no myslim ze nejsem jediny. Kolik lidi si ji treba prepalilo od kamarada? Ja neznam presne licenci ale nepouzivam Cedegu jinak nevim co bych porusoval. Mam jen to co si muzu stahnout i jinde jen slozitejsi cestou, kterou se snazim takto obejit.
      Az se mi vyplati koupit znovu Mandrivu tak to udelam neboj se 🙂
      “Vyplati” ? Musim takto premyslet nemam penize navic (bohuzel) nemuzu podporovat kde co. Kdybych mel na to neco podporovat tak to budou lidi kteri to potrebuji vic (napr. deti) Tohle ne bohuzel.
      jirka

      1. bibri | 18.02.2009 | 15:24 | Odpovědět

        >>Ceske vydani Mandrivy jsem si koupil 2x a to 2006 a 2007 a od te doby kradu, protoze na to nemam a nechce se mi to porad kupovat a taky protoze se mi powerpack libi vic nez ceska verze.

        Nejen, že jste hloupý, jak poznamenal e-ott, ale dokonce na to i okatě upozorňujete, což si zasluhuje určitý obdiv… Například by mně zajímalo, proč se vám Powerpack líbí víc než česká verze, když obě vámi zakoupené verze byly pouze rozšířením Powerpacku?

        http://www.mandrivalinux.cz/vse-o-mandriva-linuxu-2006

        http://www.mandrivalinux.cz/podrobnosti-o-ceskych-produktech-mandriva-linux-2007

        Instalační média obsahovala navíc pouze druhou vrstvu DVD – do samotného PowerPacku jsme tenkrát nezasahovali. Z čeho vychází toto vaše tvrzení, když srovnáváte dvě stejné věci? Že by hlava 22?

        >>A taky ta 2007 byla proste pro me nepouzitelna byli to vyhozene penize.

        2007 byl váš milovaný Powerpack, ano, čtete dobře, byl to Powerpack. Jestli to nevidíte tak ještě jednou: 2007 CZ BYL POWERPACK O KTERÉM TVRDÍTE, ŽE JE MNOHEM LEPŠÍ NEŽ CZ VERZE. Je to dostatečně srozumitelně napsáno? Doufám, že ano a že jste to konečně pochopil. Chybu hledejte jinde, například tam, kde bývá nejčastěji.

        >>A ty reci o tom ze Ceska verze je lepsi protoze je lokalizovana jsou k smichu

        Powerpack snad obsahuje dokumentaci v češtině? Neobsahuje! Powerpack občas (podle nálady frantíků) neobsahuje ani další české součásti – napadá mně např. nápověda k Openoffice.org, české šablony tam nejsou nikdy apod. Se slovenštinou je to ještě horší, viz např. http://www.linuxexpres.cz/distro/mandriva-linux-2009-ocami-zaciatocnickeho-profesionala. Co je tedy lépe lokalizováno, když česká verze toto obsahuje vždy? Podpora slovenštiny je tam navíc na stejné úrovni jako u češtiny. Jedna a jedna jsou dvě, jestli neumíte počítat, najděte si doučování.

        >>Ja neznam presne licenci ale nepouzivam Cedegu jinak nevim co bych porusoval. Mam jen to co si muzu stahnout i jinde jen slozitejsi cestou, kterou se snazim takto obejit.

        Neznalost neomlouvá a to ani vás: http://www.mandriva.com/en/legal/legal-faq#mandrakeclub-
        member

    6. jirka | 18.02.2009 | 16:30 | Odpovědět

      2007 jsem mel jen od vas nikde jsem ji nestahoval. Nemuzu porovnat.
      Chapu ze vas to stve jde o vasi praci.

      1. bibri | 18.02.2009 | 20:11 | Odpovědět

        >>2007 jsem mel jen od vas nikde jsem ji nestahoval. Nemuzu porovnat.

        Tak v tom případě nechápu, proč se vám, cituji o pár příspěvků výše “powerpack libi vic nez ceska verze”. Jestliže nemáte co porovnávat, tak to neporovnávejte! Ve výše uvedeném případě je to navíc zcela nesmyslné – buď si záměrně vymýšlíte, nebo neumíte číst, nebo už opravdu nevím.

        >>Chapu ze vas to stve jde o vasi praci.
        >>Ps: klidne to smazte stejne to pisu hlavne vam pane Bibr

        Kdybyste mi to chtěl napsat osobně, mohl byste to bez problémů udělat třeba mailem, je tady všude. Takto akorát veřejně šíříte nesmysly a bludy (ano, i o mé práci) a to je to, co mně asi tak nejvíc vadí. Kdybyste měl moje zkušenosti s francouzskými “originály” a kdybyste věděl, co všechno a jak se po nich musí opravovat, choval byste se stejně, to vám garantuji.

        >>To slovo hlupak vas nejak pritahuje 🙂

        Je to jen a pouze důsledek vašeho projevu. Zkuste se nad tím zamyslet, možná se to příště zlepší.

        Končím, toto je bezpředmětná debata…

    7. jirka | 18.02.2009 | 16:39 | Odpovědět

      Stahnul jsem si pouze 2008.1 a 2009.0 powerpack. To slovo hlupak vas nejak pritahuje 🙂 Takhle se vetsinou rozciluji lidi kdyz jim nekdo sahne na penize 🙂 Jinak nevim proc me porad urazite 🙂
      jirka
      Ps: klidne to smazte stejne to pisu hlavne vam pane Bibr

      1. petos | 18.02.2009 | 17:11 | Odpovědět

        > To slovo hlupak vas nejak pritahuje 🙂 Takhle se vetsinou rozciluji lidi kdyz jim nekdo sahne na penize 🙂 Jinak nevim proc me porad urazite 🙂
        Zde hlupak reprezentuje celou paletu jinych, zde nanapsatelnych slov…
        Mi na penize nesahate, ale i tak pro me jste ubohy zlodej. To me rozciluje. Zlodeji a je jedno, jestli ve vlade nebo jinde. Vy mate navic oproti jinym zlodejum tu vyhodu, ze jste schovan za anonymitu internetu.

        > Ceske vydani Mandrivy jsem si koupil 2x a to 2006 a 2007
        Kdyz to staci, tak pouzivej jen to. Pokud to nestaci, tak hold musis investovat.

        >Pocitam s tim ze to smazete tak si to precte aspon ten mazač 🙂
        >Ps: klidne to smazte
        Proc porad pisete o tom, at to nekdo smaze? Abyste mohl vykrikovat zase Cenzura!? To by prislo vhod, co? No, zatim jste slusny, nikoho nenapadate. A konec koncu svou neznalosti ze sebe jen delate hlupaka (a to uz nekolikrat)

        Svym zpusobem mi vas je fakt lito…
        Kdyz Aksavaden na foru neco potrebuje, tak se prihlasi. Jinak jako jirka

    8. jirka | 18.02.2009 | 17:24 | Odpovědět

      Pisu mazete protoze se mi to tady uz stalo. Jinak slusny jsem protoze nemam ve zvyku nekomu nadavat ani normalne a tady s tim zacinat nechci. Nadavate mi tady jen vy.
      Doslo to trochu daleko, nemel jsem v umyslu se hadat a tak to chci ukoncit. Je to nejak o nicem. Kazdy mluvime jinym jazykem – i kdyz ceky 🙂 . Ano mam tady registraci na aksavaden vzdyt jsem to psal uz driv. Kdybych se prihlasil jsem stejne anonymni jako ted. Aksavaden toho tady moc nechtel myslim skoro nic.

    9. Miroslav Cyroň | 18.02.2009 | 22:23 | Odpovědět

      Čím to je nevím, ale vím o lidech z jednoho místa Slovenska, co stejně tak nemohou použít můj zfroj. Možná to má něco společného s poskytovatelem.

  2. jar | 08.02.2009 | 21:59 | Odpovědět

    Našel by se prosím někdo, kdo má 64 bitový systém, KDE 4.1.3 z knížky pana Bíbra + oficiální aktualizace z internetu a použil tento zdroj? Velmi by mě zajímalo jak to proběhlo. Na fóru je popsáno mnoho často trochu matoucích zkušeností a jsem z toho jelen.

    1. dallasn | 09.02.2009 | 13:27 | Odpovědět

      Pod 64 bit vse probehlo ok akorat teda na Kopete, ktere jsem take pridal az nasledne po aktualizaci – jinak jsou zde chyby jako u vsech novinek – KNotify – oblibene – hlavne pada u Kopete (kdyz se nekdo prihlasi ci napise) – povetsinou kazda Notifikace vyvola chybu – zatim jsem neresil … ale jinak verze 4.2 vypada celkem slusne – vice stable release bude fajn 😉

      1. jar | 11.02.2009 | 08:23 | Odpovědět

        dallasn: I mně se nakonec podařilo. Postup:
        – instalovaná 64 bitová Mandriva 2009.0 z české knížky
        – aktualizace z českého extra DVD
        – aktualizace z internetu (výsledkem bylo funkční KDE 4.1.3)
        – přidání zdrojů, jak je popsáno v tomto článku
        – aktualizace z ovládacího centra / Aktualizovat váš systém (přibližně 370 balíčků, přes 300 MB k aktualizaci)

        Proces se někde v poslední třetině zastavil na chybě, že balíčky nejsou na FTP, přičemž tam prokazatelně byly, aktualizace zdroje nepomohla. Stáhnul jsem tedy jeden z těch údajně chybějících (kdenetwork4 ) a nainstaloval bez chyby z konzole (urpmi). Potom jsem znovu spustil ovládací centrum a aktualizace proběhla až do konce. Odmítlo se nainstalovat jen Kopete, ale šlo bez odporu přidat zvlášť z položky Správa softwaru / Instalovat a odebírat / aktualizace.

        Po spuštění nového KDE okamžitě padl Amarok a při každém odhlášení sletěl knotify. Opět podle pokynu v článku jsem nainstaloval phonon-xine (v nejnovější verzi, kterou jsem v nabídce viděl) a potom (pořadí je třeba dodržet) odstranil phonon-gstreamer. Chyby zmizely. Další upozornění ohledně ztráty nastavení prostředí je také pravdivé, ale dát si zpátky oblíbenou tapetu plochy a porovnat plasmoidy na panelu je to nejmenší. KDE 4.2 se mi zdá o něco línější než 4.1.3, ale vypadá lépe a prozatím funguje bez chyb.

        1. dallasn | 12.02.2009 | 10:07 | Odpovědět

          Nekdy je dobre cist postupy ci manualy 🙂 – takze instalace phonon-xine a odebrani phono-gstreamer skutecne resi problem s knotify; – jinak s ftp jsem u 64 bit problem nemel mozna jsem mel jen stesti…

          1. petos | 13.02.2009 | 17:30 | Odpovědět

            problem se tyka starych hdlistu…
            A toto NEJSOU OFICIALNI zdroje (jen pro poradek v terminech…)

  3. Ged | 09.02.2009 | 09:45 | Odpovědět

    V adresach ftp je chyba, navic je tam jedno ftp://

  4. Ged | 09.02.2009 | 09:49 | Odpovědět

    Jeste bych se chtel zeptat jak to je kdyz mam v soucasne dobe repozitare od Petose a chtel bych pridat tyto vice oficialni?

    Staci odebrat petosuv repozitar a pridat tento?

    1. Bloud | 09.02.2009 | 13:31 | Odpovědět

      Radší odinstalovat Petose a pridat http://ftp.kde.org

  5. jar | 10.02.2009 | 08:27 | Odpovědět

    Balíčky ubalil Helio Chissini de Castro z Brazílie. Oznámení k nim je na http://www.kdedevelopers.org/node/3882, ale na http://kde.org/download/ Mandriva (jako vždy) chybí.

  6. Eagle | 11.02.2009 | 15:26 | Odpovědět

    Tak som sa na to pozrel blizsie a je tu pravdepodobne problem s roznymi verziami KDE sucasne. Pri upgrade z 4.1.3 na 4.2.0 sa nenainstaluju vsetky baliky, niektore vyhlasuju konflikty. Ked odstranim vsetky stare (zoznam si zobrazim urpme 4.1.3), a skusal som nainstalovat vsetky nove, tak som zistil, ze v adresari x86_64 chyba task-kde4, pritom v i586 sa nachadza. Takze tu moze vznikat konflikt, ze sa pokusam nainstalovat stare task-kde4 a zaroven nove baliky 4.2.0
    Ak vsak task-kde4 nenainstalujem, vsetky baliky verzie 4.2.0 sa mi javia ako orphans.
    Digikam zblbne preto, lebo vyzaduje balik kdebase4-runtime-4.1.3-1.1mdv2009.0.x86_64, hoci je v systeme nainstalovany kdebase4-runtime-4.2.0-1mdv2009.0.x86_64
    atd…

    Verdikt je podla mna asi taky, ze nove KDE blbne tym, kto ma x86_64 system. Bez problemov by mali byt uzivatelia starsich PC s i586.

    1. Eagle | 11.02.2009 | 20:01 | Odpovědět

      Teraz pozeram, ze som vlastne nenapisal riesenie 🙂
      Odporucam pridat obidva zdroje, 32 aj 64bit, pripadne aj noarch. Upgradnut 4.2.0, nasledne odstranit vsetko co je verzie 4.1.3, nainstalovat kde-base4, potom task-kde4. Potom sice nebude fungovat kopete a digikam, ale nezobrazuje sa aspon ziadna chybova hlaska (padnuty krunner a ine dalsie aplikacie).

  7. franta851 | 12.02.2009 | 01:22 | Odpovědět

    Mám kde 4.2 z Peťošových repozitářů dnes jsem si přidal oficialní. Má to cenu,nebo necht jen ty od Peťoše? Poraďte,nerad bych si naboural mandrivu po těch hodinách ladění.

  8. RR | 13.02.2009 | 10:40 | Odpovědět

    Me se nepodarilo zdroj pridat (chyba viz. nize) a v aktualizaci systemu me balicky pro KDE4.2. zadne nenacte. Mel nekdo takovou chybu? nebo pouzit nejaky jiny zdroj pro 32bit verzi? a jaky? Diky.

    # urpmi.addmedia –update kde42-20090 ftp://ftp.kde.org/pub/kde/stable/4.2.0/Mandriva/2009.0/RPMS/i586
    přidávám zdroj “kde42-20090”
    …načítání selhalo: curl selhal: skončil s výsledkem 28

    pro zdroj “kde42-20090” nebyla nalezena žádná metadata

Leave a comment

Sorry, you must be logged in to post a comment. Login